CVE-2013-6430 Possible XSS when using Spring MVC

Severity

Low

Vendor

Spring by Pivotal

Versions Affected
  • Spring MVC 3.0.0 to 3.2.1
  • Earlier unsupported versions may be affected
Description

The JavaScriptUtils.javaScriptEscape() method did not escape all characters that are sensitive within either a JS single quoted string, JS double quoted string, or HTML script data context. In most cases this will result in an unexploitable parse error but in some cases it could result in an XSS vulnerability.

Mitigation

Users of affected versions should apply the following mitigation:

  • Users of 3.x should upgrade to 3.2.2 or later
Credit

This issue was originally reported to the Spring Framework developers by Jon Passki and the security implications brough to the attention of the Pivotal security team by Arun Neelicattu.

References

https://jira.springsource.org/browse/SPR-9983

https://github.com/spring-projects/spring-framework/commit/7a7df6637478607bef0277bf52a4e0a03e20a248

History

2014-Jan-14: Initial vulnerability report published.

Contact Pivotal
Pivotal Support