CVE-2014-1904 XSS when using Spring MVC
Spring by Pivotal
- Spring MVC 3.0.0 to 3.2.7
- Spring MVC 4.0.0 to 4.0.1
- Earlier unsupported versions may be affected
When a programmer does not specify the action on the Spring form, Spring automatically populates the action field with the requested uri. An attacker can use this to inject malicious content into the form.
Users of affected versions should apply one of the following mitigations:
- Users of 3.x should upgrade to 3.2.8 or later
- Users of 4.x should upgrade to 4.0.2 or later
This issue was discovered and reported responsibly to the Pivotal security team by Paul Wowk of CAaNES LLC.
2014-Mar-11: Initial vulnerability report published.
2014-Aug-19: Correct affected versions to exclude Spring MVC 3.2.8 and include a reference to the 3.2.x commit.